1. Home
  2. Dokumente
  3. Handbuch CS-Edit Texteditor
  4. Allgemeines

Allgemeines

Texteditor

Funktionsübersicht

  • Automatische UTF-8 Konvertierung
  • Autokorrektur
  • Code-Library
  • Code-Folding
  • Clipboard View-/Anzeige Zwischenablage
  • Suchen und Ersetzen in Dateien
  • Integriertes Syntaxhighlighting für: – C/C++ – CSS – HTML – LUA – Javascript – Pascal – Perl – PHP – Konfigurationsdateien-/Ressourcen – SQL – Visual Basic – XML
  • Umwandlung eines Textes in Groß- oder Kleinbuchstaben
  • Vertauschen von Groß-/Kleinbuchstaben
  • Schreibschutzmodus
  • Druckvorschau
  • WYSIWYG HTML-Editor (Optional)

Sie können mit CS-Edit ein neues Dokument erstellen, ein bereits vorhandenes Dokument öffnen und die vorgenommen Änderungen speichern.

Funktionen der rechten Maustaste

mausmenue

Merker setzen Haben Sie einen Textmerker gesetzt so wird dieser in der s.g. Gutterspalte wie folgt angzeigt:

Merker

Mit der Tastenkombination Strg+Q können Sie von einem Merker zum nächsten springen.

Code-Folding setzen

Code-Faltung oder Code-Folding bezeichnet eine Funktion in Editoren, um logisch zusammengehörende Quelltextabschnitte wie Klassen oder Methoden in sogenannten Folds bzw. Falten zu gruppieren. Man kann die Abschnitte dann einfach ein- und ausblenden, als ob man ein Blatt Papier faltet, um bestimmte Zeilen auszublenden.

eingeschaltet
codefolding

ausgeschaltet
kein_codefolding

Das Code-Folding ist nur bei der Sprache „Pascal“ aktivierbar, die Option können Sie über die rechte Maustaste ausschalten bzw. aktivieren.

Umlaute und Sonderzeichen in HTML-Zeichen umwandeln

Unten aufgeführte Zeichen werden bei aktivierter Option automatisch umgewandelt.

Zeichen Zeichen in HTML
Ä Ä
ä ä
Ö Ö
ö ö
Ü Ü
ü ü
ß ß
© ©
€
° °
% %
² ²
½ ½
ø ø
® ®
§ §
∑
¢ ¢
∞

Dateieigenschaften
Die aktuellen Eigenschaften eines Dokuments können Sie über den Menüpunkt Ansicht -> Eigenschaften sich anzeigen lassen.

dateieigenschaften

So erstellen Sie ein neues Dokument
Wählen Sie im Menü Datei den Befehl Neu oder klicken Sie in der Symbolleiste auf die Schaltfläche Neu. CS-Edit erzeugt ein neues Fenster und Sie können mit der Eingabe des Textes beginnen.

So öffnen Sie ein bereits vorhandenes Dokument
Wählen Sie im Menü Datei den Befehl Öffnen oder klicken Sie in der Symbolleiste auf die Schaltfläche Öffnen. Das Dialogfeld Öffnen erscheint. Klicken Sie im Feld Suchen in auf das Laufwerk, auf dem das zu öffnende Dokument gespeichert ist. Aktivieren Sie das Kontrollkästchen Schreibgeschützt öffnen, wenn Sie am Dokument nur anzeigen, aber keine Änderungen vornehmen möchten. Geben Sie im Kombinationsfeld Textformat das Format an, mit dem die Datei erstellt wurde. Dies ist nur nötig, wenn die Datei von einem DOS-Programm oder unter einem anderen Betriebssystem erzeugt worden ist. Wechseln Sie zum gewünschten Dokument, klicken Sie auf den Namen des Dokuments, und klicken Sie auf Öffnen. Tipp: Ein Dokument, das Sie vor kurzem geöffnet hatten, können Sie öffnen, indem Sie im Menü Datei, letzte Dateien auf seinen Dateinamen klicken.

So kopieren Sie einen Text in die Zwischenablage
Markieren Sie den Text, den Sie kopieren möchten.Wählen Sie im Menü Bearbeiten den Befehl Kopieren, oder klicken Sie in der Symbolleiste auf die Schaltfläche Kopieren.

So fügen Sie einen Text aus der Zwischenablage ein
Platzieren Sie die Einfügemarke an die Stelle, an der Sie den Text einfügen möchten.Wählen Sie im Menü Bearbeiten den Befehl Einfügen, oder klicken Sie in der Symbolleiste auf die Schaltfläche Einfügen.

So schneiden Sie einen Text aus
Markieren Sie den Text, den Sie ausschneiden möchten. Wählen Sie im Menü Bearbeiten den Befehl Ausschneiden, oder klicken Sie in der Symbolleiste auf die Schaltfläche Ausschneiden.

So löschen Sie einen Text
Markieren Sie den Text, den Sie löschen möchten.Wählen Sie im Menü Bearbeiten den Befehl Löschen, oder klicken Sie in der Symbolleiste auf die Schaltfläche Löschen. Sie können das Dokument nach Wörtern oder Zeichen durchsuchen. Darüber hinaus können Sie Wörter und Zeichen durch einen bestimmten Text ersetzen lassen.

So suchen Sie nach einem Text
Wählen Sie aus dem Menü Bearbeiten den Befehl Suchen. Das Dialogfeld Suchen erscheint. Geben Sie im Feld Suchen nach den Suchtext (Zeichen oder Wörter) ein, und klicken Sie anschließend auf Weitersuchen. Um eine weitere Stelle zu finden, an welcher der Text vorkommt, klicken Sie noch einmal auf Weitersuchen. Wenn Sie das Dialogfeld Suchen bereits geschlossen haben, können Sie die Suche nach dem Text mit der Taste F3 fortsetzen.

So ersetzen Sie einen Text durch einen anderen
Wählen Sie aus dem Menü Bearbeiten den Befehl Ersetzen. Das Dialogfeld Ersetzen erscheint. Geben Sie im Feld Suchen nach die zu suchenden Zeichen oder Wörter ein. Geben Sie im Feld Ersetzen durch den Text ein, durch den der Suchtext ersetzt werden soll. Klicken Sie auf Weitersuchen und dann auf Ersetzen. Wenn Sie alle Textstellen auf einmal ersetzen möchten, klicken Sie auf Alles ersetzen.

So speichern Sie den Text als PDF-Datei ab

Wählen Sie aus dem Menü Datei den Menüpunkt „Speichern unter“ und im Dialogfenster den Dateityp PDF-Datei aus.

dateityp_pdf.jpg